"low" FPS and low GPU/CPU usage

I have to ~~ discuss ~~ complain about an issue regarding this game's performance. I don't know if it happens for everyone or just me, but this issue has persisted even after I've built a new computer so I'm certain that this is not an issue on my end. I've had this issue for a while now, it annoyed me but I didn't care until I've upgraded my PC and gotten a 144 hz monitor because now it's causing actual issues. The game is hardly utilizing any of my PC's resources and not giving me enough fps. I still average at around 180 fps when not much is going on and tends to drop all the way down to 90's in bigger fights. Now a lot of people will say "durr you have over 60 just shut up and enjoy it" but as for whatever reason FreeSync doesn't work with League and I couldn't fix it, the game stutters every time I drop bellow 144 fps... And that happens a lot, even in small early game skrimishes. So I have 2 options: play the game at high refresh rate but have it stutter in critical moments, or have it be the only game that I'm playing at 60 hz(and 60 hz gives me a headache at this point). I've also noticed something even weirder, as my framerate drops when a lot is going on, so does the GPU usage. Here are some screenshots of it in action: This is at the start of the game: 300+ fps and ~35% usage https://cdn.discordapp.com/attachments/422376914209079308/547056094107926578/Untitled2.png Then when the laning starts: 160 - 210, but ~25% usage https://cdn.discordapp.com/attachments/422376914209079308/547057551456337920/1.png Now this is where I start having issues, 90 fps and 18% usage. Yes, there is a lot going on but why is the usage dropping with the framerate? Shouldn't it be the other way around? It really annoys me at this point and I want to poke my eyes out due to the stuttering because again, I can't get FreeSync to work with this game. https://cdn.discordapp.com/attachments/422376914209079308/547056095185600522/Untitled.png Take in mind that this is the framerate that I'm getting with a $1000 PC, on medium settings with shadows, eye candy and event map accents off. Before you tell me to update my drivers or to see if anything is bottlenecking - my drivers are all up to date (I even tried reinstalling them) and as you see the temps are fine (because again, neither CPU nor GPU are being utilized much)... This is literally the only game that has this issue, other games are utilizing the GPU properly and giving the me framerate that I should be getting. Also that 100% usage peak on HWMonitor is just a spike that lasted for a second during the loading screen, you can see that from the temps. Usually when it's maxed out at 100% usage it runs at 65-75 degrees. If anyone has any workarounds or fixes, I'd be thankful but otherwise - Riot, please fix.
Share
Report as:
Offensive Spam Harassment Incorrect Board
Cancel