I can't log in (stuck on Authentication)

Yesterday I tried to play Invasion on Onslaught and I couldn't connect to the game. Got the unable to connect to the game info and the game frozen on black screen so I closed league with task manager and then opened a new one. When I tried to log in I got stuck on authenticating. Before that I've played like 5 games without any troubles. Things I've done so far: - restarted PC - reinstalled lol - used Hextech Repair Tool - used leage full repair - restarted router - unplugged ethernet cable - tried different server (EUW) and different accounts - flushed dns All other multiplayer games (OW, CS:GO, Dark Souls 3) that I've tried so far run without any problems. Has anyone encountered similiar issue and how did u solved it?
Share

We're testing a new feature that gives the option to view discussion comments in chronological order. Some testers have pointed out situations in which they feel a linear view could be helpful, so we'd like see how you guys make use of it.

Report as:
Offensive Spam Harassment Incorrect Board
Cancel