"Error - Unspecified error" when freshly downloading LoL

So I just installed a fresh windows, formatted everything, for a slight performance boost. Alas, I cannot get League of Legends to download I just get this screen during downloading (It stops around 1780 MB during the first phase) http://i.imgur.com/x19AnY1.png While checking my logs I cannot detect anything strange. Here is the log: https://www.sendspace.com/file/005yyh Now this is not really urgent, but it bugs me that I cannot play the game :/ I have a Windows XP 32 bit due to old hardware, but league worked before the fresh installation without any issues. Can anyone please help, it would be greatly appreciated EDIT: I seem to have fixed it by scanning for bad sectors on my hard drive.

We're testing a new feature that gives the option to view discussion comments in chronological order. Some testers have pointed out situations in which they feel a linear view could be helpful, so we'd like see how you guys make use of it.

Report as:
Offensive Spam Harassment Incorrect Board