d3dx9_39.dll is missing

After installing a recent update, I received an error message, as I was disconnected from a game. Each time I tried connecting to a game, I would be able to choose my champion but I could never reach the loading screen. The switch from champion select to loading screen is where the problem is. After it fails to load the game for me, I am brought back to the client, where I am unable to press play, since the button just isn't there anymore. The error message told me the following: ''the program can't start because d3dx9_39.dll is missing from your computer. Try reinstalling the program to fix this problem.'' So i did. I reinstalled league of legends- I tried installing directx9. I tried downloading the .dll and pasting it into system32 and syswow64. I tried repairing the client. None of these attempts have been useful and I still can't play the game, which is a bummer. I like the game. PLease help me. Thank you in advance. {{champion:67}}
Report as:
Offensive Spam Harassment Incorrect Board