Alpha/BETA Client underperforming in every aspect for over 3 patches now.

Afternoon EU, For the last couple of patches now (Patch 7.7 ; patc 7.6 ; Patch 7.5 ), the clinet hasnt been performing optimally. I thought he problems would have been fixed in patch 7.6 but on the contrary, it got worse, and now in patch 7.7 the client is still not performing at an optimal level like in previous patches (7.4 and previous ones). I get STUCK in the PVP menu every single day. Everytime I click on a gamemode, the client doesnt respond, it freezes. After playing a game in Summoners Rift and I feel like playing an Aram, when I click on Aram it tells me to PICK A ROLE!! (IN ARAM!!!) http://i.imgur.com/yALCUZD.jpg (And that is ONE of MANY, thankfully I made a screen shot of that one) I tried using low spec mode too, and boy its a nightmare. Low spec mode is worse than normal spec mode, its slower, its less responsive, its just a disaster... I had to go back to the legacy client because I just couldnt handle it. Riot, prioritize the client, because its been underperforming for over 3 patches now. That shouldnt happen. And it´s not just me, I have been talking to friends both PC and laptop users, the majority experiencing the same issues, on a lower scale. ___ Yes, I know the client is in BETA stage (I believe, if its fully launched, then god help us), but you guys should be keeping the new client under control. I mean... Just look at the ARAM image, how is that even possible?! It could be a connection issue, but it aint. I got wifi amplifier and I am recieving everything (hell, my family tells me to stop playing LoL at certain hours because I suck up all the internet...). Anyway, im getting out off topic here. ___ The client is underperforming, both the normal spec mode and lower spec mode (And lower spec mode is even worse by the way, I dont even know how that is even possible). The client was working magnificently in patch 7.4 with each new patch, the client is getting worse. I am asking despreately, PLEASE take a look at this. It´s been 3 patches now. I would understand all this if it were a one patch or two patch problem, but THREE?!.... I am at a lost for words. http://i.imgur.com/k3C4Xog.png
Share
Report as:
Offensive Spam Harassment Incorrect Board
Cancel