: i have tried this and it seems to mitigate quite a lot of the problem. Still not clear what the actual problem is.
also look into g-sync and freesync, that have solved some input lag for me in some games, now that nvidia cards support freesync displays, or g sync software can be turned on in most freesync displays.
: Is this input lag in my head? Driving me crazy
in options/game, toggle the "use movement preditcion" that worked for me at high fps. also you need to lock the fps to just a few fps below monitor refresh rate, try ingame fps limiter or as i do, msi afterburner and set it to 142fps since i got a 144hz monitor.

Xuddish

Level 61 (EUNE)
Lifetime Upvotes
Create a Discussion