Jubileu (EUW)
: Authenticating
WEll i've managed to get this working. i've installed some windows updates and rebooted my rooter, but no idea what actually made it wotk. Ty for the help :)
: Are you using wired or wifi connection? Are you using Windows 10? The problem is, that if you were launching Client without administrative rights it might got some corrupt files when updating, but your problem is authentication related so I don't think that's the case. Maybe you should portward your router to allow League to communicate with its servers without any blockage? EDIT: You can try one thing that helped me out a year ago when same problem happened, simply put wrong password and try to login, when it will say that you've put wrong password, type in the correct one and see if that works :P
Wired connection and using windows 10. I've even re-installed the game, running the installer as admin, and still cant log in. And yes i did the wrong password method too :p
: Okay, then do [this](https://imgur.com/a/CbaMGRo) and then [that](https://imgur.com/a/C1syEWA) and try again. Let me know if it works :P
Tried both, nothing... :( Thanks anyway, i've opened a ticket
: First thing to try is to launch the Client as an administrator, simply right-click on it and choose "Run as administrator". See if that works, let me know.
Tried it too.. still authenticating
Rioter Comments
Rioter Comments
TimeSteedGG (EUNE)
: Rito PLS look at those fan made skins
Sorry mate, never seen a fanart skin taken to the game. Dont get much hopes
Rioter Comments
Rioter Comments


Level 100 (EUW)
Lifetime Upvotes
Create a Discussion