kamen185 (EUW)
: Install fails at DX9
Its downloads: Riot Games - League of legends - Prerequisites - Dx9 When I go into this folder, its gives me the option to run DXSETUP and when I do it says it is incompatible after trouble shooting
GuznaNafta (EUNE)
: https://boards.euw.leagueoflegends.com/en/c/help-support-en/2rrJEfnK-directx-error-causes-failure-in-installing-lol
I cant Download Direct X User-runtime
Rioter Comments

kamen185

Level 33 (EUW)
Lifetime Upvotes
Create a Discussion